Notifications
Clear all

Does the Alchemy PowerPack work with Alchemy Player 1.55?


cocoazenith
(@cocoazenith)
Active Member
Joined: 4 months ago
Posts: 13
Topic starter  

I guess I summed it all in the topic title. Would be interested in buying the library
during the current sale but I won't if it doesn't work...


Quote
PlugInGuruForums
(@pluginguruforums)
Owner/Guru Admin
Joined: 2 years ago
Posts: 242
 

That is a very good question that I have not looked into myself. I'm about to host my weekly Livestream but I'll load up Logic on my MacBook Pro with the latest version of Logic and see if I can get it to work. If you decide to buy it, I have always offered a 100% money back guarantee if you're not totally satisfied with your purchase for any reason. Cheers!

Life is Sound / Sound is Divine
www.pluginguru.com


ReplyQuote
cocoazenith
(@cocoazenith)
Active Member
Joined: 4 months ago
Posts: 13
Topic starter  

Thank you, John! I will buy it then and try the compatibility myself. Keeping my fingers crossed that I won't have to apply for a refund! 


ReplyQuote
SSquared
(@ssquared)
Member
Joined: 2 years ago
Posts: 178
 

@cocoazenith The PowerPack is made specifically for the new Alchemy inside Logic.  I don't think this will work with the original version from Camel Audio.  The original libraries can import into the version in Logic, but not the other way around.

Ableton Live 10, Omnisphere, Native Instruments (Pianos), Spire, Diva, SynthMaster, Alchemy 1.55, Addictive Keys, Unify


ReplyQuote
cocoazenith
(@cocoazenith)
Active Member
Joined: 4 months ago
Posts: 13
Topic starter  

@pluginguruforums @ssquared

I had to give it a shot seeing there was no definitive answer on this...

So I bought the library and tried it. So I can now confirm that, unfortunately, Alchemy 1.55 cannot load any the patches from the
Alchemy Powerpack. Not even the ones that John made for the old Factory Bank... 😑  It scans and lists them but that's about it. 


ReplyQuote
Share: