Notifications
Clear all

Synth1 Updated

4 Posts
2 Users
0 Reactions
1,164 Views
 csp
(@csp)
New Member
Joined: 4 years ago
Posts: 4
Topic starter  

Ichiro just updated Synth1 today.  I have it working in Logic 10.6.2 and Unify 1.5 as an AU. 

It seems to trigger the message: Logic quit unexpectedly after I quit Logic. (update: Restart fixed this)

Have you tested it yet?

https://daichilab.sakura.ne.jp/softsynth/index.html

 

This topic was modified 3 years ago by csp

   
Quote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4435
 

@csp

I haven't tested the new Synth1 beta yet, but it would not surprise me if it crashes. The Synth1 code is quite old, and probably finicky. Also, the AU wrapper updates were done not by Toda-san, but by someone else named "eijis-pan". Having tried for years to contact Toda-san without success, I'm now trying to reach "eijis-pan", but I'm not confident.

Unfortunately, the VST version of Synth1, for which we have just finished creating over 16,000 Unified patches, is now "abolished". Please take note that the Unified patches will not work with the newer AU plug-in, which appears to be the only one available for Mac now.


   
ReplyQuote
 csp
(@csp)
New Member
Joined: 4 years ago
Posts: 4
Topic starter  

@getdunne

Thanks for the information on your efforts to get the Synth1 VST working again. The AU version works perfectly in Logic. It also runs fine in Unify 1.5. No crashes in Stand Alone Unify or the AU Unify.  After quitting Logic, sometimes the "Logic unexpectedly quit" error message appears which is not a big deal.  This seems to be OK in Unify with the AU version.  I have a large patch library saved in Logic, which still worked even though the Synth1 GUI was blank, so its great to see the GUI functioning for programming patches.  Hopefully, you'll be able to get the VST version running again to rescue the 16,000 Unify patches.


   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4435
 

@csp

The VST version of Synth1 never stopped working, and remains the only target for the cross-platform unified library. The problem is that, at some point, new users may no longer be able to download it.

Bear in mind that any Unify patches you create using the Audio-Unit version of Synth1 can never* be shared with Windows users.

(* Well, not without significant additional reverse-engineering and programming effort by me.)


   
ReplyQuote
Share: