Notifications
Clear all

BlueARP Not Working/Editable


iMagesOunds
(@imagesounds)
Active Member
Joined: 2 years ago
Posts: 9
Topic starter  

Condition:

  • While using Unify, I cannot get BlueARP to function correctly in Cubase 10 Pro or Ableton 10.  It plays the presets just fine but I cannot make edits or create my own patterns within the main matrix window.  No matter where I click in the matrix area nothing happens. 
  • BlueARP does work in Unify standalone mode though
  • BlueARP does work as a standalone plugin in my hosts

System Info:

Windows 10 Home, Version 10.0.18363 Build 18363.

 

This topic was modified 2 years ago by iMagesOunds

Quote
getdunne
(@getdunne)
Member Admin
Joined: 2 years ago
Posts: 2954
 

Thanks for this feedback. This may be related to the "always on top" window issue, i.e., the BlueARP window may not be getting "input focus" with the settings you have chosen.

I'll look into this, but for now you may have to develop your custom BlueARP patterns either by loading BlueARP directly into the DAW (you can save new presets in BlueARP itself, then load them later into BlueARP in Unify), or in Unify stand-alone.

Please keep us informed about any work-arounds you find.


ReplyQuote
iMagesOunds
(@imagesounds)
Active Member
Joined: 2 years ago
Posts: 9
Topic starter  

Thanks for looking into this and your responsiveness. 

I want give an update on my end.

  • I am able to get BlueARP working as expected in Cubase Pro 10 with the workaround options we discussed which is good!   
  • However no luck in Ableton 10 (although the workaround does work for Multis issue in Ableton for me).

ReplyQuote
saif_sameer
(@saif_sameer)
Member
Joined: 2 years ago
Posts: 60
 

@imagesounds

Try to update to the latest version of BlueArp, it carries the same number 2.2.11, but Oleg (Graywolf) fixed some stuff.

 

"In heaven, all the interesting people are missing."
Friedrich Nietzsche


ReplyQuote
iMagesOunds
(@imagesounds)
Active Member
Joined: 2 years ago
Posts: 9
Topic starter  

@saif_sameer  I downloaded and installed the latest version.  No luck - issue persists.   


ReplyQuote
getdunne
(@getdunne)
Member Admin
Joined: 2 years ago
Posts: 2954
 

Because Oleg didn't increase the version number, the installer may not overwrite the older version.

I have been in touch with him, and we hope to have a full update available with our planned April update for Unify.

If you can't wait until then, locate and manually delete the BlueARP DLL (windows) or .vst file (Mac), then reinstall BlueARP. See the link for your platform under https://pluginguru.net/unify/manual/doku.php?id=installing#what_to_do_if_you_have_problems for where to locate these files.

Please note making changes like this is at your own risk. If you mess up your installation, please don't expect us to fix it for you.


ReplyQuote
iMagesOunds
(@imagesounds)
Active Member
Joined: 2 years ago
Posts: 9
Topic starter  

@getdunne I will wait.  Thanks for the info.   


ReplyQuote
thesandbox
(@thesandbox)
New Member
Joined: 2 years ago
Posts: 3
 

I had the same issue and had to swap the .dll in the Unify folder as well with the latest "2.2.11" and it worked after that.


ReplyQuote
getdunne
(@getdunne)
Member Admin
Joined: 2 years ago
Posts: 2954
 

The next Unify update will be coming in mid-April, and will include an even newer build of BlueARP. We're sorry this happened. Oleg tried to do us a favor by sending us an update, but it seems he didn't test thoroughly (neither did we--lesson learned) and although he fixed the crash bug, he broke editing in the process. Welcome to the fun, fun world of software development!


ReplyQuote
Padster13
(@padster13)
Eminent Member
Joined: 2 years ago
Posts: 20
 

I have also solved the Blue Arp "unresponsive to editing" issue using the recommendation above. I downloaded the latest Blue Arp from the website. As stated, the Blue Arp version number is the same as the version recorded in Unify1.0.12, (ie Blue Arp vers 2.2.11). I temporarily moved the existing non editable Blue Arp .dll to a safe place and copied the downloaded 64 bit .dll in its place and it is now editable again.


ReplyQuote
Leszek 1953
(@leszek-1953)
Member
Joined: 2 years ago
Posts: 362
 

(@imagesounds)

I also had a problem with BlueArp, I downloaded from the page that Shanne gave me, I changed the file, I saved the .dll file in VSTPlugins (Win 10 PC) and everything works. ( http://graywolf2004.net/wp/?page_id=35)

Les.


ReplyQuote
Share: