Notifications
Clear all

Crackling and distortion

8 Posts
5 Users
1 Reactions
1,841 Views
(@seagreg)
Estimable Member
Joined: 4 years ago
Posts: 87
Topic starter  

In some patches I have to deal with crackling and distortion.

For Example: Ping pong pianos

Thanks to the cpu meters this is correlated with a CPU usage over 100%. 

my computer is a i7 7700 with 32GB of ram and 1TB SSD.

Audio device Typ : ASIO / Yamaha Steinberg USB ASIO Version 2.0.4. 

buffer size : 768 samples 17.4 ms

Audio Interface : Yamaha Montage 7 

 

During a chat I  already mentioned this problem and Shane gave me the advice to turn the Master effects down. But even if the are nearly off the cracklings remains. 

greetings from Bavaria

Seagreg


   
Quote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4435
 

When CPU meters hit 100% or higher, you will get audio crackles due to buffer underruns (meaning Unify cannot fill new 768-sample buffers as quickly as the audio interface needs them).

In this case, the high CPU usage is due to OBXd (which is not super-efficient) having to keep too many notes sustaining. Open OBXd and reduce the Release knob under Loudness Envelope, and CPU usage will drop considerably.


   
ReplyQuote
(@seagreg)
Estimable Member
Joined: 4 years ago
Posts: 87
Topic starter  

@getdunne

to worked.
Is my computer underpowered?
How does the original patch work on other systems ?

 


   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4435
 

@seagreg

No your computer is fine. That patch is a bit of a pig on any system, if you play lots of notes.


   
ReplyQuote
(@zastrozzi)
Member
Joined: 4 years ago
Posts: 2
 

I was having a similar issue with the patch, "KEY - Dreamy Beginnings Piano Pad" (one of my favorites). I found that by turning off the "OSC key sync" switch in DEXED fixed the issue.

Hope this helps.


   
ReplyQuote
(@larry-ludwick)
Trusted Member
Joined: 4 years ago
Posts: 78
 

Another thought for some of your user created patches. I had some very nice sounding patches, but once when I loaded one, it was breaking up and crackling. I knew when I created it, it sounded clean. But I then realized that some vsts don't load samples quickly enough and playing the patch before the loading finished can cause the breakups when samples are not fully loaded.

 

I noted this when I had several Omnisphere patches for sounds that had a long load time. By waiting a few seconds to allow the loads to finish, everything was smooth as could be. Just something to consider.


   
pluginguru reacted
ReplyQuote
(@morganmusic)
Member
Joined: 4 years ago
Posts: 16
 

Here's a notion that I might send directly to Shane but I thought I would post it here first.  I got a great response from him with regard to distortion and crackling issues and I thought I might repost the content of that email here for all to see first, to put my notion second and in context.

"Re “crackling”, I note in passing that it’s all too easy to make patches that clip in Unify, but I’m sure you’re able to distinguish between clipping distortion and “crackling” due to audio buffering problems.

Whenever you see Unify’s audio meters going into the red, this means you’re trying to do more audio processing per buffer than can be done in the available buffer-time (see https://pluginguru.net/unify/manual/doku.php?id%3Dcpu-meters&source=gmail&ust=1630631181853000&usg=AFQjCNFuWnpD5Aqs62AlcgIDJo8gaqopx w"> https://pluginguru.net/unify/manual/doku.php?id=cpu-meters ), so you’re pretty much bound to get crackling. The first thing to try is increasing your buffer size; try 512 or even 1024.

I currently use 512 in Logic on my Old Dual-Core MBP i7 with 16GB RAM

Unify does have some overhead, but the lion’s share of the processing is accounted for by plug-ins. If you create patches with many plug-ins, you’ll stress your CPU. Disabling the Master effects layer will reduce Unify’s overhead somewhat because it will skip the final audio-layer processing step entirely.

The most likely reason why you would hear less crackling in stand-alone mode than in a DAW (assuming the same buffer sizes) is that the DAW has some overhead of its own."

So.... my thought was and Question IS.... "Would it be possible, Practical, or even useful" to have the program/ app (that is, of course, Unify) somehow AUTOMATICALLY adust audio buffer size to accommodate to CPU demand of various patches?"  Perhaps when they load?  I note there are LOTS of choices in Unify's Buffer Size selection, allowing to customize this parameter.

In most DAWS it takes quite a while for these changes to take effect, effectively rebooting or reloading, or resetting the DAW.  I have yet to try to Unify in Studio 4 my Other DAW but that will be another thread.


   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4435
 
Posted by: @morganmusic

"Would it be possible, Practical, or even useful" to have the program/ app (that is, of course, Unify) somehow AUTOMATICALLY adust audio buffer size to accommodate to CPU demand of various patches?"  Perhaps when they load?

Short answer: No.

Even if I could do this, it would only be for Unify stand-alone. In a DAW, it's the DAW that sets buffer sizes.

There are probably better ways to optimize CPU on a per-patch basis, which I will be looking into in the long term.


   
ReplyQuote
Share: