Notifications
Clear all

Enabling or disabling layer mute produces pops

2 Posts
2 Users
0 Likes
408 Views
(@paull)
Member
Joined: 4 years ago
Posts: 26
Topic starter  

Hi Shane,

On a couple patches, when I enable or disable mute, I'm getting a pop. This only occurs if the track is playing a sound when I toggle mute.

I tried switching between Generic ASIO and Windows drivers but that didn't have any affect.

I can reproduce the problem using either "PolyMIDI 4 Random Thoughts" or "Ardzin Beats". Also, specific to the Ardzin Beats patch, if I'm not playing a note, mute all the layers, then play a note, I can still hear all the sounds. As soon as I disable mute on any layer, I only hear that layer.

Unify 1.1.14 standalone, Windows 10 Pro 64bit v1909


   
Quote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4410
 

@paull Two separate issues here:

  • Pops when un-muting: Mute operates on the audio output of the layer; if the layer is producing sound, un-muting will switch it on very abruptly, so you'll here a click. I will look into implementing some kind of soft switching.
  • Mute all layers, sound continues: This is a bug. It never occurred to me to mute ALL layers, but it seems "mute all" effectively means "mute none". It's not specific to the Ardzin patch; on other patches you'll get the same effect if you mute the AUX layers too.

Thanks for the feedback.


   
ReplyQuote
Share: