Notifications
Clear all

[Sticky] Mac Catalina says "Unify.component will damage your computer"


getdunne
(@getdunne)
Member Admin
Joined: 2 years ago
Posts: 2523
Topic starter  

New user @forgandenny reports getting the dreaded "Unify.component will damage your computer" from MacOS 10.15.7 Catalina, even with the latest Unify v1.3.2.

This message usually appears only if the certificate used to sign the plug-in binary has expired or has been revoked. I've just checked our certificates, and everything seems OK. This might be a temporary issue. I suggest rebooting your Mac and trying again.

If this problem persists, please do keep us posted here. Certificate issues are VERY serious, and if we suddenly have a problem, I need to know.


RainBro liked
Quote
forgandenny
(@forgandenny)
New Member
Joined: 3 months ago
Posts: 3
 

Still the same after a restart.

This is the validation tool output:

validating Audio Unit Unify by PlugInGuru:

AU Validation Tool
Version: 1.7.0
Copyright 2003-2019, Apple Inc. All Rights Reserved.
Specify -h (-help) for command options

--------------------------------------------------
VALIDATING AUDIO UNIT: 'aumu' - 'Unfy' - 'Kuhl'
--------------------------------------------------
Manufacturer String: PlugInGuru
AudioUnit Name: Unify
Component Version: 1.3.2 (0x10302)

* * PASS
--------------------------------------------------
TESTING OPEN TIMES:
COLD:
FATAL ERROR: OpenAComponent: result: -1,0xFFFFFFFF


validation result: couldn’t be opened

 


ReplyQuote
getdunne
(@getdunne)
Member Admin
Joined: 2 years ago
Posts: 2523
Topic starter  

I'm so sorry you're having this trouble.

Apple's app-notarization service is down right now -- a rare occurrence. It's quite possible their certificate-checking services may be affected as well.

On the off chance that anything went wrong with your installation, you may want to locate Unify.component in /Library/Audio/Plug-Ins/Components, delete it (drag to Trash, then empty Trash), and run the Unify installer one more time.


ReplyQuote
forgandenny
(@forgandenny)
New Member
Joined: 3 months ago
Posts: 3
 

@getdunne I've reinstalled it as you said and now it works! Thank you very much!


ReplyQuote
Share: