Notifications
Clear all

MacOS Ventura - Icon just bounces at startup, hover over says not responding

7 Posts
2 Users
1 Likes
416 Views
eakwarren
(@eakwarren)
Eminent Member
Joined: 2 years ago
Posts: 12
Topic starter  

Just a note that Unify 1.9.1 seems to have issues starting in MacOS Ventura 13.0.1. The icon just bounces in the dock and a right-click says Application Not Responding. The icon stops bouncing after a bit, but the Unify window never comes up. Clicking on the icon, the Unify top menu doesn't come up. Have to Force Quit.

All the Best,

Eric


   
Quote
Topic Tags
(@getdunne)
Illustrious Member Admin
Joined: 3 years ago
Posts: 3907
 

@eakwarren

Oh dear. Thank you for the report.

EDIT: Others have reported no problems with Ventura. I'm not set up to test just yet. In the meantime, what type of Mac are you using, and are you sure you changed NOTHING else, other than updating the OS? Also, do you use an external drive for Unify's main data folder?

Please try temporarily renaming the files:

  • ~/Library/Application Support/PlugInGuru/PluginList.xml (in YOUR Library folder, not the system-wide one)
  • Libraries/presets.db in Unify's main data folder

Then try starting Unify, and see if it works.


   
ReplyQuote
eakwarren
(@eakwarren)
Eminent Member
Joined: 2 years ago
Posts: 12
Topic starter  

@getdunne

About This Mac info attached. I don't recall anything else changed and I don't use an external drive for Unify's data folder.

Renaming those files does allow Unify to start. But of course the presets are gone.

Thanks,

Eric

 
Edit: Confirmed that restoring those renamed files causes Unify to not load. So they're likely corrupt.
This post was modified 3 months ago by eakwarren

   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 3 years ago
Posts: 3907
 

@eakwarren

I doubt the files are actually corrupt. It's more likely to be a permissions problem. Check permissions using Get Info, and update to ensure you have read/write access. Before doing so, though, please compress them to a single .zip. If updating permissions does not fix the issue, attach the .zip here and I'll have a look myself.


   
ReplyQuote
eakwarren
(@eakwarren)
Eminent Member
Joined: 2 years ago
Posts: 12
Topic starter  

@getdunne Looks like permissions are fine. Attaching here for review. Thank you! 🙂


   
ReplyQuote
eakwarren
(@eakwarren)
Eminent Member
Joined: 2 years ago
Posts: 12
Topic starter  

And here's those files zipped.


   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 3 years ago
Posts: 3907
 

@eakwarren

Thank you for the files. This is mysterious indeed. Both files seem just fine to me; I can even swap them into the appropriate folders on my Windows PC, and Unify will load normally. No evidence of any corruption that I can see. The modification dates indicate that presets.db (your patch database) was modified recently (Nov 17), but PluginList.xml (your Known Plug-Ins list) was modified much earlier (June 24). I will try the same test on my Mac later.


   
eakwarren reacted
ReplyQuote
Share: