Notifications
Clear all

Not playing Midi Files right...again


Kendall W Cochran III
(@pbeprod)
Member
Joined: 2 years ago
Posts: 267
Topic starter  

@getdunne

Sorry that I've sent so many questions while you've been gone but,  I'm playing tonight in Bristol. I'm in the process of setting up my "Play" tracks inside Logic Pro, I can un-mute each track for that specific time event. Each track has an instance of Unify with it's "Patch" I'm playing in a bar so the bit I'm doing in a version of 99 bottles of beer, which is a Joke based on limited time to play I could do 99 verses, well anyways. The drum part is an Rx2 file being played by MIDIbox using the Rx2's Midi file that was spit out by Recycle. Quite a while back I don't remember if you remember the problem  I was having that after the first time through it wouldn't play the midi file all the way through. The difference between then and now is now I have a After touch keyboard so I edited the Velocity curves on the "Instrument" all the way, and inside MIDIbox all the way up. thinking maybe it had to do with after-touch. I then went into edit the file and make sure that each not is exactly the same length and starts on it's part of the "Beat" Now here's kicker, it only does this inside Logic. It doesn't do it in the Standalone version.  I haven't used my Mac in a show in over 1.5 years. Except when I use it at Church, for which I use the Standalone version. It's doing that for all of my Rx2 files as far as I can tell inside Logic pro. I'm not really needing an answer. Just thought it was odd that being in the DAW would cause this issue. Also I just checked Reason and it did it too there. But not in Standalone. These kinds of things give me a headache. Again this is on a Mac running MacOS 11.6.5


Quote
getdunne
(@getdunne)
Member Admin
Joined: 3 years ago
Posts: 3448
 

Hi Kendall,

Sorry I couldn't answer sooner, but while I was in Europe I only had a phone with me, and couldn't realistically answer Forum questions. I just got back yesterday, and there are three pages of unread posts waiting.

I can't tell exactly what your problem is based on what you've written, although I thank you for providing so much detail. The most likely issue is that inside Logic (or any DAW), Unify will usually follow the DAW's transport. You may need to switch off "follow host" in the affected patches and re-save them, AND make sure you haven't got "On Patch Load, always set follow host" checked in Unify Settings. (That's a new setting added in Unify 1.8, so it may be on by default now, though it didn't even exist before.)

I wish I could make this simpler, but it's inherent in the notion of a plug-in that loads other plug-ins. The transport (aka playhead) is the only mechanism to synchronize multiple plug-ins' playback, and inside a DAW, you must either sync to the DAW's transport, or not, and syncing to the DAW's transport is best for nearly all DAW scenarios. Using a DAW to play live is an unusual scenario.


ReplyQuote
Kendall W Cochran III
(@pbeprod)
Member
Joined: 2 years ago
Posts: 267
Topic starter  

@getdunne 

Yeah which is why in my view Unify is so powerful, I see it’s power in using the standalone live and why I suggested the feature of visual midibox, so I can skip using a DAW. People’s reaction to what I do “How are you doing that?!??” I’m constantly showing people Unify. I’m doing standup comedy this weekend, Unify will be there.


ReplyQuote
getdunne
(@getdunne)
Member Admin
Joined: 3 years ago
Posts: 3448
 

@pbeprod

I've often thought that, over time, Unify should acquire a few more DAW-like features.

Did my suggestion about follow-host fix your playback woes?


ReplyQuote
Kendall W Cochran III
(@pbeprod)
Member
Joined: 2 years ago
Posts: 267
Topic starter  

@getdunne 

I had actually tried that and several other things it plays through correctly the first time.  I did go into Midi Editor and edit the midi file, and resave in case the "Reason" anomalies were showing themselves again. But here's a link to a video showing what's going on. https://www.dropbox.com/s/81nvkk3h85bm0m3/Video%20showing%20end%20of%20file%20skipping.zip?dl=0


ReplyQuote
getdunne
(@getdunne)
Member Admin
Joined: 3 years ago
Posts: 3448
 

@pbeprod

Thanks for the video. Very strange. You appear to be running in Logic, but I can see that Logic's transport isn't running. Two thoughts:

  1. Please try changing the Logic project's sample rate, i.e., if it's 44.1 kHz, switch to 48 kHz, or vice versa, and tell me if the problem persists.
  2. Can you share the MIDI file with me?

ReplyQuote
Kendall W Cochran III
(@pbeprod)
Member
Joined: 2 years ago
Posts: 267
Topic starter  

@getdunne 

No changes by changing the Sample rate. The issue I can't figure is that it's playing it correctly on the Mac in Standalone mode. So shouldn't the midi file be ok? I did edit it on my PC with Midi Editor then put it back on the Mac bare bones before I contacted you orginally. But I attached it, maybe you'll find something.

Thanks


ReplyQuote
Share: