Notifications
Clear all

Omnisphere Crashing when Changing Unify Patches and Omnisphere is open

6 Posts
2 Users
1 Likes
513 Views
(@nedrob519)
Eminent Member
Joined: 2 years ago
Posts: 18
Topic starter  

Omnisphere was working fine in Unify. I just bought Megamagic Guitars 1 and 2 and now when I change patches in Unify and Omnisphere is open, Unify crashes immediately.

I own a number of Omnisphere libraries from you and now all of them crash Unify when I open a new patch and Omnisphere is also open. 

I've tried running with both Rosetta on and off. No difference.

Mac with latest OS and all Unify and Omnisphere are updated to latest version. 

Here's the crash report.

 


   
Quote
(@nedrob519)
Eminent Member
Joined: 2 years ago
Posts: 18
Topic starter  

The above was all done running Unify in Standalone mode.

I now tried Unify inside Ableton Live 11. Same results. If I change any Omnisphere patch and Omnisphere is open (all now inside of Live 11) Live crashes immediately. 

Latest version of everything. 

Thanks. 

Ned


   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 4 years ago
Posts: 4367
 

@nedrob519

UPDATE: I believe have been able to reproduce this problem, and it does appear to be an Omnisphere issue. I will take this up with the developers at Spectrasonics.

The crash occurs when Unify attempts to re-use an instance of Omnisphere whose GUI window is open. The work-around is to close all Omnisphere windows manually, before loading a new patch in Unify.


Thank you for the report, and most especially for including the crash report. It seems to be Omnisphere itself that is crashing, apparently when an instance is re-used for the new patch. Please refer to this manual page. I have attached a (zipped) modified version of the standard ReuseDenyRules.xml file. Please try replacing the existing file at ~Library/Application Support/PlugInGuru/PluginRules-Unify with this one. Quit all instances of Unify, and of your DAW if applicable, then re-run Unify and see if the problem persists.

Also, you mentioned that this started happening after you installed MegaMagic Guitars v1 and v2. It seems unlikely that just installing a new .omnisphere file inside Omnisphere itself would cause this behavior, but I suppose anything is possible. I'd like to try to reproduce this on my Mac. Could you please provide a short sequence of steps which seems to crash every time on your machine?


   
ReplyQuote
(@nedrob519)
Eminent Member
Joined: 2 years ago
Posts: 18
Topic starter  

Thanks for confirming the issue. I look forward to an update from Spectrasonics. Hopefully it won't take too long. 🙂


   
getdunne reacted
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 4 years ago
Posts: 4367
 

@nedrob519

I just heard back from my contact at Spectrasonics, who sent me a beta version that I have confirmed resolves this issue. Expect the fix to appear in a new official update very soon.


   
ReplyQuote
(@nedrob519)
Eminent Member
Joined: 2 years ago
Posts: 18
Topic starter  

Great news! Thanks for the update!


   
ReplyQuote
Share: