Notifications
Clear all

Unify only sounds as long as midi messages are received..

12 Posts
4 Users
3 Likes
505 Views
(@andre-pascal)
Active Member
Joined: 2 years ago
Posts: 6
Topic starter  

Hi. I am a new user so this is probably a newbie question.

When using Unify as a plugin in my daw (cubase 12 pro) everything works fine. After releasing a key the envelope release and FX is sounding, like programmed in the patch. But in the standalone version its different. As soon as i release the keys the sound stops. No release and no FX. But the release and FX can be heard as long as one key is pressed. I cannot find a solution. I can do with some suggestions.

regards, Andre Pascal.


   
Quote
(@craigr68)
Member
Joined: 3 years ago
Posts: 210
 

This might be causing it.  Click on the triangle like icon at the lower left which says "transport controls" when you hover over it.  Set the Trigger from MIDI/Quick Stop to Manual Start/stop.  Some VSTs behave this way and it's been discussed a few times here on the forum.  I went thru the same thing with Syntronik VST when I first got Unify.


   
Robert.P reacted
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4410
 

@andre-pascal

Unify uses an internal transport to synchronize multiple plug-ins, and the default mode keeps this transport running only while at least one key is pressed. There is also a "follow host" function, which is on by default when Unify is used as a plug-in in a DAW, which overrides this behavior and simply follows the DAW's transport instead.

Unify itself doesn't stop sounding when the transport stops, but as @craigr68 points out, some third-party plug-ins do. Xfer Records' Serum is an example, and it offers a preference checkbox to turn this auto-stop behavior off.

When I'm using Unify stand-alone just to play different instrument plug-ins, I often switch its transport trigger mode to Manual Start/Stop when I run into one that auto-stops like this.


   
ReplyQuote
(@andre-pascal)
Active Member
Joined: 2 years ago
Posts: 6
Topic starter  

Thank you both for the reply. I have tried the tip to set the 'follow host' function to manual start removed link I used an init sound, put in a guru sampler and set the envelope with a long release time. Unfortunately, the sound stops when releasing all keys. As long as i hold one key down, I can hear the release sound of the other notes. But when releasing that last key no more sound can be heard, the sound stops immediately. So the behaviour didn't change after changing the follow host. Are there any other settings which can change this behaviour?

btw. when using the onscreen keyboard with the mouse there is no problem. The notes sounds untill the end.

This post was modified 2 years ago by Andre Pascal

   
ReplyQuote
(@andre-pascal)
Active Member
Joined: 2 years ago
Posts: 6
Topic starter  

Right.....I found something out about my roland D50. I was using that keyboard. And when releasing a key it sends 2 messages:

'Note off' and an 'All notes off'. And that is probably the reason why it is cutting off midi notes and sound. When I for example use my Wavestate that synth only sends 1 message after releasing a key, namely 'Note off'. So it is because of the behaviour of the synth which is used to play Unify. And there is no way to change the behaviour of the D50. The double message is by default. Thats a shame. I love playing the D50 keyboard. As soon as i play the D50 in the DAW with Unify, there is no problem.

This post was modified 2 years ago by Andre Pascal

   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4410
 
Posted by: @andre-pascal

Right.....I found something out about my roland D50. I was using that keyboard. And when releasing a key it sends 2 messages:

'Note off' and an 'All notes off'.

That's unexpected. Please provide details about how you determined this.


   
ReplyQuote
(@andre-pascal)
Active Member
Joined: 2 years ago
Posts: 6
Topic starter  

I used the software tool midiox. Midiox shows the 2 messages after releasing a key.


   
ReplyQuote
Robert.P
(@robert-p)
Reputable Member
Joined: 4 years ago
Posts: 293
 
Posted by: @andre-pascal

I used the software tool midiox. Midiox shows the 2 messages after releasing a key.

I'm not sure if it's gonna work, but you can try to place a "MIDI Filter" on your MIDI layer before the instrument and block "cc 123" (all notes off)


   
getdunne reacted
ReplyQuote
(@craigr68)
Member
Joined: 3 years ago
Posts: 210
 

I see there's some history to the D50 doing this according to this article.  Article seems to suggest cc123 block fixes it.

https://community.cantabilesoftware.com/t/roland-d-50-midi-cc-123-all-notes-off/2157

 


   
ReplyQuote
(@andre-pascal)
Active Member
Joined: 2 years ago
Posts: 6
Topic starter  

Right. I have been using the D50 for more then 20 years in my setup and never experienced any problems. But that was most of time with cubase as my daw. Probably CC 123 is filtered out. Will look into that.  But thanks for the info. Still learning things about the D50 after so many years of use.


   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4410
 

You can arrange for specific MIDI CC or note-on messages to be suppressed on a per-controller basis using a MIDI Controller File.

In present versions of Unify, you could do this by adding a line such as

cc 123 macro/100

This causes CC#123 messages to set macro knob number 100, which doesn't exist, and hence the macro-set operation fails, but the MIDI message is still filtered out of the MIDI stream on its way into Unify.

For the next release, I've added an option to say "suppress" instead of an invalid parameter path like "macro/100".


   
Robert.P reacted
ReplyQuote
(@andre-pascal)
Active Member
Joined: 2 years ago
Posts: 6
Topic starter  

Thank you. I will add this line to the file. Cheers, André 


   
ReplyQuote
Share: