Notifications
Clear all

Option to send "note off" on stop

12 Posts
2 Users
3 Reactions
813 Views
(@ro-mix)
Estimable Member
Joined: 4 years ago
Posts: 119
Topic starter  

If some layers have Latch on, then on stop latched notes still do not send "note off" message. So when i start playback once again, first touch of the triggering note does not work, so one have to press it again. I think it could be nice to have an option (or just this behavior) to unlatch all latched channels on stop.


   
Quote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4459
 

@ro-mix

When you say "on stop", do you mean when stopping playback in a DAW?


   
ReplyQuote
(@ro-mix)
Estimable Member
Joined: 4 years ago
Posts: 119
Topic starter  

@getdunne I mean when stopping playback in Unify. I use standalone, but i think same mechanic will play when Unify is in sync to daw.

This post was modified 3 years ago 2 times by RO-mix

   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4459
 

@ro-mix

I'm sorry but I still don't quite follow you. Can you please post step-by-step instructions to reproduce this issue?


   
ReplyQuote
(@ro-mix)
Estimable Member
Joined: 4 years ago
Posts: 119
Topic starter  

Hm.. it happens in my preset. If i start from zero it works as i expect. Watch this preset(C1 triggers BD). If i stop Unify during BD playing, then on next press playback starts but BD does not. If i copy-paste BD layer to upper level preset - it works.

This post was modified 3 years ago 4 times by RO-mix

   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4459
 

@ro-mix

You have the outer-level Transport set to "MIDI / Manual Stop". Try changing to "MIDI / Reset".


   
RO-mix reacted
ReplyQuote
(@ro-mix)
Estimable Member
Joined: 4 years ago
Posts: 119
Topic starter  

Nice, it works now! Another similar question. I try to make Microtoniq (which has its own playback control) to play same way, when i press a key and latch. For this i tried to put it in another Unify layer, and set this layer to Quick stop and switch Follow Host off. In this case this Microtoniq layer does not play at all. MIDI/Latch does not do it either. I switched Follow Host back, but Trigger mode in embedded layer changes nothing. Can i make latch playback of a layer and unlatch on next touch somehow?

This post was modified 3 years ago 4 times by RO-mix

   
ReplyQuote
(@ro-mix)
Estimable Member
Joined: 4 years ago
Posts: 119
Topic starter  

Problem with midi restart if i have melodic instrument, beat restarts with every note.. Is Trigger control supposed to be independent for embedded layers? If i set both levels to MIDI/restart - again same behavior like in a topic..

This post was modified 3 years ago 3 times by RO-mix

   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4459
 

@ro-mix

Transport gets set to "Follow Host" by default in embedded Unify layers, so it syncs with the outer layer. Try switching it off; that should allow you to have the inner and outer transports operate independently.

It's difficult for me to advise on these questions, because I don't know exactly what effect you're trying to achieve. Synchronization of multiple layers is a complex topic, and becomes much more so when you add embedded Unify layers.


   
ReplyQuote
(@ro-mix)
Estimable Member
Joined: 4 years ago
Posts: 119
Topic starter  

I just wanted to inner layer start when i pres a key and stop when i press again, but could achieve it using modes.


   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4459
 
Posted by: @ro-mix

I just wanted to inner layer start when i pres a key and stop when i press again, but could achieve it using modes.

See attached image. Set embedded Unify transport thus:

  • Follow Host OFF (this is the most important).
  • The default Trigger mode will do
  • I strongly suggest setting the note-range limits so that only keys in the bass range start/stop the grooves
    • The range I selected may be much tighter than you want

Set the outer Unify transport in whatever way works:

  • I don't recommend the "MIDI / Manual Stop" mode unless you need it for something else
  • Check or un-check Follow Host based on how you want Unify to work with your DAW's transport

   
RO-mix and mj_prod reacted
ReplyQuote
(@ro-mix)
Estimable Member
Joined: 4 years ago
Posts: 119
Topic starter  

Experimenting with latch in Unify in DAW i noticed weird behavior when using BlueArp to drive something WHEN DAW IS STOPPED. (it does not happen when i just trigger Punch 2 playback in stopped state)
It plays with lags, and every beat it has some glitch. Probably trying to sync with host. "Follow host" does not affect this behavior. When daw is playing - all good. Quick stop mode.

Here is audio. First part is with DAW stopped. Last part is when DAW playing.
https://mega.nz/file/eTIQ1LaC#Uh7LKjCrQzW4Fbi86miCn3C92e5r-XZRN2Q3gfMJ52o

Patch
https://mega.nz/file/eCJSnRxB#_LHeXmetpMW22lA3c5HjzYkkhIlL6PTj3GGF888bOzQ

This post was modified 3 years ago 2 times by RO-mix

   
ReplyQuote
Share: