Notifications
Clear all

Diva Unified Library

9 Posts
2 Users
0 Reactions
395 Views
(@robertpeveler)
Estimable Member
Joined: 4 years ago
Posts: 173
Topic starter  

I have discovered something odd about the Diva unified library.  If I create a patch with a drum loop, and set a tempo that is other than 120 bpm, this plays fine.  If I then load a BPM patch from the Diva unfiied library as "new Unify layer" by right clicking, the loaded patch insists on playing at 120 bpm.  I have to manually adjust the tempo in the "child" Unify layer to get it to sync.  If I open the "child" layer and select a different Diva patch from the available library, it is again reset to 120 bpm, and out of sync.  This doesn't happen with patches from e.g. the Zebra Unified library, and I haven't noticed it with any others, though haven't checked them all.

Any ideas as to what might be going on?  I thought the Unify layer within a Unify layer would always follow the "parent" layer tempo?  I guess it must be something to do with the way the Diva library patches have been saved?

Thanks for thoughts.


   
Quote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4452
 

@robertpeveler

I'm having trouble reproducing this. When you initially create your drum loop patch, are you setting the tempo in Unify's transport, or directly in Diva? You should set it in Unify; the other way won't work as you expect, because tempo-setting is one-way, host to plug-in, not the other way around.


   
ReplyQuote
(@robertpeveler)
Estimable Member
Joined: 4 years ago
Posts: 173
Topic starter  

Thanks Shane - yes I understand that.  I am playing a rex file in the top layer, using zampler in this case (but the same happens whatever vst I use), and I then set the bpm manually to something other than 120, and the rex file plays back at the correct adjusted tempo.

Next, I select the Diva library in the Unify browser, right click a patch, and select “load as new Unify layer”.  The patch duly loads into a new layer, but is out of sync, and when you open the second Unify layer, it shows tempo of 120.  I can sync it by manually adjusting to the new tempo, but if I then select a different Diva patch from the browser within the second layer, it resets to 120 again, and out of sync.

By contrast, patches from the Zebra library behave exactly as I would expect, and load at the tempo of the top layer.  I suppose the next thing to try would be to re-download the Diva unified guru file.  This seems to be the only library that shows this.

I presume there shouldn’t be any way to set a Unify layer to load at a different tempo from the top layer?
(I guess that might be a handy feature in some cases though, probably as a ratio of the master tempo.  I know you can do that when MIDI box is involved).


   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4452
 

@robertpeveler

Check the Transport in the embedded Unify right after loading the embedded Unify layer. The "follow host" box should be checked. If not, the patch you're embedding might be defined with it not checked. If so, please specify the exact patch and I can check it here.

In Unify Settings, there's a checkbox to "on patch load, always set follow host". If you check that, it should force embedded patches to load with "follow host" checked. (Let me know if it does not.)


   
ReplyQuote
(@robertpeveler)
Estimable Member
Joined: 4 years ago
Posts: 173
Topic starter  

Thanks - yes that's the issue - as far as I can see, none of the patches in the Diva unified library have this box checked, though I haven't looked at every single one - there are 475!  Tedious.


   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4452
 
Posted by: @robertpeveler

Thanks - yes that's the issue - as far as I can see, none of the patches in the Diva unified library have this box checked, though I haven't looked at every single one - there are 475!  Tedious.

Thanks for spotting that. I can fix them automatically. I'll discuss with John.


   
ReplyQuote
(@robertpeveler)
Estimable Member
Joined: 4 years ago
Posts: 173
Topic starter  

Great thanks.


   
ReplyQuote
(@robertpeveler)
Estimable Member
Joined: 4 years ago
Posts: 173
Topic starter  

Actually I have just noticed that this is off as default, when starting up Unify standalone, or after an "init".  Is there a reason for it be off by default, or might it be better to be on?  I don't think there is a setting for this on the settings page?


   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4452
 
Posted by: @robertpeveler

Actually I have just noticed that this is off as default, when starting up Unify standalone, or after an "init".  Is there a reason for it be off by default, or might it be better to be on?  I don't think there is a setting for this on the settings page?

Follow-host is off by default in Unify stand-alone, because there is no "host" to follow. It should be on by default in a new embedded Unify instance, but this can be overridden by whatever patch you load into it (which is the root of the problem you originally reported).


   
ReplyQuote
Share: