Notifications
Clear all

Kontakt 7 is VST3 only - how do I open my TOC-2 library

5 Posts
3 Users
1 Reactions
160 Views
(@milford59)
Eminent Member
Joined: 3 years ago
Posts: 22
Topic starter  

I am not an expert so I hope someone can help - I have upgraded to Kontakt 7 and now I can't open any of my TOC-2 patches - I get an error message and having read the help on the PluginGuru pages, I think its because Unify can't find the VST plugin - because Kontakt 7 only has a VST3 plugin.

It all worked fine before I upgraded my Kontakt.... 

Is there anything I can do to get it working like before ?

 

Thanks very much.


   
Quote
(@terrybritton)
Member
Joined: 3 years ago
Posts: 117
 

Did you rescan the VST3 plugins from the plugin dialog? 


   
ReplyQuote
(@milford59)
Eminent Member
Joined: 3 years ago
Posts: 22
Topic starter  

Posted by: @terrybritton

Did you rescan the VST3 plugins from the plugin dialog? 

Thanks for your reply.

Yes - I deleted the Kontakt 7 VST3 plug-in from the dialog….. then I re-scanned and it loaded it again….. I think the problem is that Kontakt 7 no longer provides anything other than the VST3 plug-in (and TOC-2 library was probably written to work with a VST plug-in ONLY ?)

 

Any other suggestions will be gratefully received.

 

This post was modified 5 months ago by milford59

   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4453
 

Posted by: @milford59

Yes - I deleted the Kontakt 7 VST3 plug-in from the dialog….. then I re-scanned and it loaded it again

The original Kontakt VST (VST2, not VST3) plug-in is probably still on your system. You just need to find it again and re-scan it. It will continue to work just fine to load patches created with the VST.

There's no problem with having both VST and VST3 versions of a plug-in in Unify's Known Plug-Ins list. When loading new instances of Kontakt, you would most likely use the very latest one, but the older one should also be in the list, so Unify knows where to find it when loading older patches.

 


   
ReplyQuote
(@milford59)
Eminent Member
Joined: 3 years ago
Posts: 22
Topic starter  

Posted by: @getdunne

Posted by: @milford59

Yes - I deleted the Kontakt 7 VST3 plug-in from the dialog….. then I re-scanned and it loaded it again

The original Kontakt VST (VST2, not VST3) plug-in is probably still on your system. You just need to find it again and re-scan it. It will continue to work just fine to load patches created with the VST.

There's no problem with having both VST and VST3 versions of a plug-in in Unify's Known Plug-Ins list. When loading new instances of Kontakt, you would most likely use the very latest one, but the older one should also be in the list, so Unify knows where to find it when loading older patches.

 

Thanks very much - I will try that.

 

EDITED- To say - YES !!  That works - I found the old VST2 plugin on my other laptop where I hadn't yet upgraded Kontakt.

Thank you VERY much for your help.

 

This post was modified 5 months ago by milford59

   
getdunne reacted
ReplyQuote
Share: