Notifications
Clear all

[Sticky] Seeking help for Unified Korg Wavestation library

Page 2 / 2

thsve
(@thsve)
Estimable Member
Joined: 2 years ago
Posts: 187
 

For the time being, I have made a simple TouchOSC (latest version) "script" to control Wavestation from e.g. an iPad.

You can download the script here: https://www.dropbox.com/s/eff57i2c9cxz65z/Wavestation.tosc?dl=0

Here is a short video demonstrating it: https://youtu.be/ycnP4JEwT1w  

Win 10/Cubase Pro 11/Wavelab 8/Spectrasonics all/NI 13/Izotope MPS2Serum/Cthulhu/MusicLab guitar vsts/etc


JeremyH liked
ReplyQuote
JeremyH
(@zinct)
Member
Joined: 1 year ago
Posts: 433
 

@thsve

Thanks Thomas, looks good; I will give it a go 👍 

Having completed all the O2 MM Guitars for John yesterday, I'm now working on Korg Collection 3 starting with Prophecy. One annoyance is that if you filter the patches then stepping through them ignores the filtering, but I have found a workaround.  

This post was modified 3 months ago by JeremyH

ReplyQuote
zipidowski
(@zipidowski)
Active Member
Joined: 4 months ago
Posts: 7
 

@zinct 

This is great news! I also got Korg Collection 3 as I had already M1 Le and got upgrade offer to whole collection very cheap, only 199 USD which I think is really great value! I really like Triton sounds.


JeremyH liked
ReplyQuote
JeremyH
(@zinct)
Member
Joined: 1 year ago
Posts: 433
 
Posted by: @zipidowski

@zinct 

This is great news! I also got Korg Collection 3 as I had already M1 Le and got upgrade offer to whole collection very cheap, only 199 USD which I think is really great value! I really like Triton sounds.

Yes, I did exactly the same thing @zipidowski. I had been on the fence for ages but they really knocked it out the park for Collection 3 so thought I would jump in.

 


ReplyQuote
thsve
(@thsve)
Estimable Member
Joined: 2 years ago
Posts: 187
 

@zinct 

Had some spare time and was a bit bored, so I put together a script to unify Wavestation. I’m running it now and it takes just under 10 minutes per bank. At first I had no method to step through the patches, but then it struck me that I could use my TouchOSC for Wavestation🤗.

I’ll send it to you when I’m done.

Win 10/Cubase Pro 11/Wavelab 8/Spectrasonics all/NI 13/Izotope MPS2Serum/Cthulhu/MusicLab guitar vsts/etc


JeremyH liked
ReplyQuote
JeremyH
(@zinct)
Member
Joined: 1 year ago
Posts: 433
 

@thsve

I like your thinking Thomas, that must be a first. How do you synchronise TouchOSC on the iPad with your script? 


ReplyQuote
thsve
(@thsve)
Estimable Member
Joined: 2 years ago
Posts: 187
 

@zinct 

I will send you a description.

Win 10/Cubase Pro 11/Wavelab 8/Spectrasonics all/NI 13/Izotope MPS2Serum/Cthulhu/MusicLab guitar vsts/etc


JeremyH liked
ReplyQuote
thsve
(@thsve)
Estimable Member
Joined: 2 years ago
Posts: 187
 

I have some weird behavior with Wavestation in Unify. As mentioned above I have Unified some of the factory patches. The problem is that when I start Unify and go to one of the Wavestation patches, Unify crashes directly.

From Event viewer:
Faulting application name: Unify.exe, version: 1.5.3.0, time stamp: 0x60dc7842
Faulting module name: WAVESTATION.dll, version: 2.2.0.0, time stamp: 0x60f7bbae
Exception code: 0xc0000005
Fault offset: 0x00000000000e1411
Faulting process ID: 0x362c
Faulting application start time: 0x01d78c7b4d40bb9b
Faulting application path: C:\Program Files\PlugInGuru\Unify\Unify.exe
Faulting module path: C:\Program Files\VSTPlugIns\KORG\WAVESTATION.dll
Report ID: 8a0fd1bb-5d81-4d0c-bcda-a9aeacbb0f39
Faulting package full name:
Faulting package-relative application ID:

It doesn't matter which patch I try to open.

If I, before trying to open a saved patch, choose Wavestation as instrument in an empty patch there are no problems opening the saved Wavestation patches after that.

Edit:
The problem goes away if I open any instrument or patch(other that Wavestation) once. After that the Wavestation patches loads as expected.

Win 10/Cubase Pro 11/Wavelab 8/Spectrasonics all/NI 13/Izotope MPS2Serum/Cthulhu/MusicLab guitar vsts/etc


JeremyH liked
ReplyQuote
JeremyH
(@zinct)
Member
Joined: 1 year ago
Posts: 433
 

@thsve

Exactly the same happening here Thomas. 


thsve liked
ReplyQuote
getdunne
(@getdunne)
Member Admin
Joined: 2 years ago
Posts: 2850
Topic starter  

@thsve

I will try to reproduce this when I get back from my travels. The crash summary is pretty minimal but suggests a bug in Wavestation itself; however it's entirely possible that Unify is at fault. If I can get in direct touch with the development team at Korg, we should be able to track these issues down.


ReplyQuote
thsve
(@thsve)
Estimable Member
Joined: 2 years ago
Posts: 187
 

While waiting for Shane to communicate with the Korg people about getting metadata, I decided to unify what we have so far. You can download it here: https://www.dropbox.com/s/83xmpsyys3je8y9/Unified%20-%20KORG%20Wavestation.guru?dl=0

Description is missing for CARD1-6 and KLC and the tags are taken directly from the Wavestation categories for these banks.

The content is compiled by myself, @zinct, @heyjosh and @getdunne. I've compiled all our xlsx-files into one containing all banks/cards (attached).

I took the liberty to unify some of the prefixes since we used slightly different ones.

See post https://forums.pluginguru.com/postid/10625/ . There is some weird behavior when opening a Wavestation patch in some cases.

Jeremy: Before installing this you need to remove the one I sent you!

In order to use this library you need a full version of UNIFY and own Wavestation and have the VST2 plugin registered in Unify.

Enjoy.

Win 10/Cubase Pro 11/Wavelab 8/Spectrasonics all/NI 13/Izotope MPS2Serum/Cthulhu/MusicLab guitar vsts/etc


JeremyH liked
ReplyQuote
JeremyH
(@zinct)
Member
Joined: 1 year ago
Posts: 433
 

@thsve

Thanks Thomas! Much appreciated 👍 


ReplyQuote
thsve
(@thsve)
Estimable Member
Joined: 2 years ago
Posts: 187
 
Posted by: @thsve

I have some weird behavior with Wavestation in Unify. As mentioned above I have Unified some of the factory patches. The problem is that when I start Unify and go to one of the Wavestation patches, Unify crashes directly.

From Event viewer:
Faulting application name: Unify.exe, version: 1.5.3.0, time stamp: 0x60dc7842
Faulting module name: WAVESTATION.dll, version: 2.2.0.0, time stamp: 0x60f7bbae
Exception code: 0xc0000005
Fault offset: 0x00000000000e1411
Faulting process ID: 0x362c
Faulting application start time: 0x01d78c7b4d40bb9b
Faulting application path: C:\Program Files\PlugInGuru\Unify\Unify.exe
Faulting module path: C:\Program Files\VSTPlugIns\KORG\WAVESTATION.dll
Report ID: 8a0fd1bb-5d81-4d0c-bcda-a9aeacbb0f39
Faulting package full name:
Faulting package-relative application ID:

It doesn't matter which patch I try to open.

If I, before trying to open a saved patch, choose Wavestation as instrument in an empty patch there are no problems opening the saved Wavestation patches after that.

Edit:
The problem goes away if I open any instrument or patch(other that Wavestation) once. After that the Wavestation patches loads as expected.

For some reason, I am not able to recreate this anymore. I have no idea why🤔 .

 

Win 10/Cubase Pro 11/Wavelab 8/Spectrasonics all/NI 13/Izotope MPS2Serum/Cthulhu/MusicLab guitar vsts/etc


ReplyQuote
JeremyH
(@zinct)
Member
Joined: 1 year ago
Posts: 433
 
Posted by: @thsve
Posted by: @thsve

I have some weird behavior with Wavestation in Unify. As mentioned above I have Unified some of the factory patches. The problem is that when I start Unify and go to one of the Wavestation patches, Unify crashes directly.

From Event viewer:
Faulting application name: Unify.exe, version: 1.5.3.0, time stamp: 0x60dc7842
Faulting module name: WAVESTATION.dll, version: 2.2.0.0, time stamp: 0x60f7bbae
Exception code: 0xc0000005
Fault offset: 0x00000000000e1411
Faulting process ID: 0x362c
Faulting application start time: 0x01d78c7b4d40bb9b
Faulting application path: C:\Program Files\PlugInGuru\Unify\Unify.exe
Faulting module path: C:\Program Files\VSTPlugIns\KORG\WAVESTATION.dll
Report ID: 8a0fd1bb-5d81-4d0c-bcda-a9aeacbb0f39
Faulting package full name:
Faulting package-relative application ID:

It doesn't matter which patch I try to open.

If I, before trying to open a saved patch, choose Wavestation as instrument in an empty patch there are no problems opening the saved Wavestation patches after that.

Edit:
The problem goes away if I open any instrument or patch(other that Wavestation) once. After that the Wavestation patches loads as expected.

For some reason, I am not able to recreate this anymore. I have no idea why🤔 .

 

@thsve

It's still happens here Thomas albeit a lot less frequently. The 10th patch in the list (BASS - Bass1 In Yo Face(ROM10)) seems to make it crash/exit more than others when selected as the first patch after opening Unify but it still works OK more often than not. 

I tried opening the latest beta Unify (beta 154) then opening that patch as the first one; it crashed on the 7th try.

I then tried opening the current release of Unify (1.5.3) then opening that patch; it didn't crash after 10 attempts (but it did crash once when I tried it before these 10 attempts). 

🤔


ReplyQuote
thsve
(@thsve)
Estimable Member
Joined: 2 years ago
Posts: 187
 

@zinct

This is really weird. I am on 1.5.3 and have not been able to crash it in spite of trying to repeat your "experiment" a lot more than 10 times🤓.

Win 10/Cubase Pro 11/Wavelab 8/Spectrasonics all/NI 13/Izotope MPS2Serum/Cthulhu/MusicLab guitar vsts/etc


ReplyQuote
Page 2 / 2
Share: