Unify Note Off Glit...
 
Notifications
Clear all

Unify Note Off Glitch

5 Posts
2 Users
1 Likes
197 Views
(@gengastar)
Active Member
Joined: 10 months ago
Posts: 3
Topic starter  

Hello to all sorry in advance for my incompetence I am running windows 10 on PC with cubase 12 and focusrite scarlett 6 Gen 2 and i am having audio problems. If i boot the PC with no other apps running and open Unifi standalone i get a horrible click through my monitors after every note off on the keyboard. I have had this same setup for a couple of years without any problems and it has only just reared it ugly head. I am hoping somone has had the same problem and can advise on a quick and easy fix thanks for any help in advance


   
Quote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4410
 

@gengastar

Does this clicking happen with every plug-in instrument in Unify, or only some?

Please open Unify's Transport view and change the trigger mode from "MIDI / Quick Stop" to anything else. Let me know if this fixes the problem. If so, there may be other ways to solve it.


   
ReplyQuote
(@gengastar)
Active Member
Joined: 10 months ago
Posts: 3
Topic starter  

@getdunne Hi this only happens with certain instruments BASS-Hard Filler Acid is one which is most obvious.

Changed the "MIDI / Quick Stop" to any of the other settings and all of the others worked fine so all is good thank you very much. 

I dont really understand the proper usage of these midi settings so will have a play around.

Thanks again

 

 


   
ReplyQuote
(@getdunne)
Illustrious Member Admin
Joined: 5 years ago
Posts: 4410
 

Posted by: @gengastar

@getdunne Hi this only happens with certain instruments BASS-Hard Filler Acid is one which is most obvious.

Changed the "MIDI / Quick Stop" to any of the other settings and all of the others worked fine so all is good thank you very much. 

I dont really understand the proper usage of these midi settings so will have a play around.

AH, you didn't mention that you were using a Serum library. This is a known Serum issue. You can fix this once and for all with a Serum preference:

  • In Serum, click Global, then under Preferences, switch off "Silence Note + Effect Tails when Host Transport Stops"
  • Click the little disk icon to the left of the heading "Preferences", to save the change. (Don't forget this step!)

What's happening is that Unify has its own "Transport", which keeps track of BPM tempo, time-signature, and song-position. This is what keeps multiple plug-ins working in sync. With the default trigger mode "MIDI / Quick Stop", this Transport starts running when the first MIDI note-on is received, and stops (and resets to bar 1, beat 1) when the last note-off is received.

The problem arises because some plug-ins quickly cut off their audio output when they see their host's Transport stop running. This makes sense in a DAW, where the Transport stops when you explicitly stop playback (or recording and playback), and you probably don't want to hear notes and effects ringing out. But as you see, it doesn't works so well in a live-host like Unify, where the Transport must start and stop at other times, so most plug-ins which do this output-cutoff trick also provide a way to turn it off.

The Transport page in the Unify manual has more details.

 


   
ReplyQuote
(@gengastar)
Active Member
Joined: 10 months ago
Posts: 3
Topic starter  

@getdunne wow u da man Thank you for your pearls of wisdom


   
getdunne reacted
ReplyQuote
Share: