Notifications
Clear all

[Solved] Unable to load preset "Chill GTR Phrase BMP - 10 Rhythm Ny Guitar". Seems to be missing


radford
(@radford)
Active Member
Joined: 1 month ago
Posts: 10
Topic starter  

I can't seem to load the preset "BPM ARP- 10 Rhythm Ny Guitar". Is this a known issue ? I just updated to the V1 final version today.

 

This topic was modified 3 weeks ago by radford

Quote
getdunne
(@getdunne)
Member Admin
Joined: 2 years ago
Posts: 2850
 

@radford

I think what happened is that that patch was re-saved under a new name ("BPM ARP - 10 Rhythm Soft Rain"), but this confuses Unify's "quick" algorithm for rebuilding the patch database. The basic solution is to perform a full rebuild of the database.

Just to be safe (because something in Unify is clearly not behaving perfectly), I advise making a safe backup copy of your existing patch database file first:

  • Click the gear icon to open Unify's Settings view
  • Click the "Open..." button to reveal the main Unify folder
  • Double-click the "Libraries" folder to open that one instead
  • Locate the file "Presets.db" (the patch database) and rename it to e.g. "OLD Presets.db".

Perform a full rebuild by holding down ALT (Option on Mac) while clicking the lightning-bolt icon at the top of the patch browser. This will completely erase and rebuild the Presets.db file. It may take a few minutes if you have many libraries. When it's done, you should see that that the entry for that patch has changed from "BPM ARP - 10 Rhythm Ny Guitar" to "BPM ARP - 10 Rhythm Soft Rain", and it should open correctly.

Click the "heart" icon at the top of the patch browser, to display only patches you had previously marked as favorites, and make sure they are all listed as you would expect. If everything looks OK, you can delete the "OLD Presets.db" file now. If not:

  • Follow the steps above again, to locate the rebuilt Presets.db file
  • Make a zip of both "Presets.db" and your "OLD Presets.db"
  • Post the zip here, attached to a comment, and I will try to restore the favorites for you.

Even if everything goes fine, please let me know that with another comment here. Thanks for your patience.


ReplyQuote
radford
(@radford)
Active Member
Joined: 1 month ago
Posts: 10
Topic starter  

wow. that works! Thanks so much! All my favorites were restored too. I'm not sure if I have to redo the bindings for memorymode though since the dropbox patches John provided linked to an old version of memorymode. But I don't mind re-doing them.

 


ReplyQuote
radford
(@radford)
Active Member
Joined: 1 month ago
Posts: 10
Topic starter  

oops. spoke too soon. So, the samples for BPM ARP - 10 Rhythm Soft Rain seem to be missing. Nothing plays when I press a key with that preset selected. Everything else is okay.


ReplyQuote
radford
(@radford)
Active Member
Joined: 1 month ago
Posts: 10
Topic starter  

Ok. figured it out. For some reason, the preset had tracks 2 and 3 disabled by default. I just turned it on and it works.

 


ReplyQuote
radford
(@radford)
Active Member
Joined: 1 month ago
Posts: 10
Topic starter  

ok.. apologies again. I'm really dumb. I just realized the sample has a delayed start. Everything works. Thanks again!

 


ReplyQuote
Share: